Ergebnis 1 bis 11 von 11

Thema: Mehrere Geräte im Programmiermodus

  1. #1
    Registriert seit
    Jan 2016
    Ort
    Speyer
    Beiträge
    6

    Mehrere Geräte im Programmiermodus

    Hallo, und schonmal danke, dass Ihr meine Rookie-Frage ernst nehmt...

    Bei meinem KNX-Testaufbau habe ich schon seit längerem ein Problem, dass mich umtreibt. Ich versuche mich kurz zu fassen:

    Aufbau/Vorbedingungen:

    • Minimalaufbau aus MDT IP Router (SCN-IP100.02), MDT Spannungsversorgung (STC-0604.01) und GIRA Stetigregler (210003).
    • PC ist via Ethernet / ETS5 verbunden
    • Diverse andere Komponenten, egal ob GIRA oder MDT funktionieren am Bus einwandfrei.
    • Adressen: IP Router (mit Email-Fkt.) (1.1.0 / 1.1.1), Spannungsv. (1.1.2), GIRA S-Regler (ohne bzw. 15.15.255)
    • Hauptline "1" ist IP, "1.1" ist TP

    Problem:

    • Die Adresse des GIRA Stetigregler (210003) lässt sich nicht programmieren. Es befinden sich immer mehrere Geräte im Programmier-Modus (oder gar keins).
    • Dazu passt: Sobald im P-Modus sieht die ETS Diagnose "Geräte im Programmiermodus" 1-4 Geräte, ständig wechselnd.
    • Wenn der Programmiermodus des Stetigreglers beendet wird, befindet sich sofort kein Gerät mehr im P-Modus.
    • Die Spannungsversorgung hat eine rote Diagnose-LED "Bus Error", die immer 2x pro P-Modus Anfrage der ETS blinkt.
    • Auch bei einem "großen" Aufbau mit diversen GIRA/MDT-Komponenten gibt es keinerlei Probleme, solange nur der Stetigregler nicht am Bus hängt.

    Was ich schon versucht habe (ohne Auswirkung):

    • Foren / Internet-Recherche
    • Studium der Datenblätter
    • Austausch Stetigregler
    • Wechsel des LAN-Switches (nur PC, Switch, LAN)
    • Wechsel von PC auf Notebook
    • Alle Komponenten mehrfach neu verkabelt
    • Alle Komponenten mehrfach neu programmiert
    • Alle Firmware-Komponenten sind aktuell
    • Minimalaufbau
    • P-Adresse ETS verändert
    • Backbone verändert

    Meine Vermutung:

    • Bug im IP-Router?
    • Trotz Standard inkompatibel: IP-Router + S-Regler

    Gerne steuere ich noch weitere Infos bei.

    Herzlichen Dank!

  2. #2
    Avatar von EIB-Freak
    EIB-Freak ist offline KNX-Professional Firmenmitglied (Administrator)
    Registriert seit
    Aug 2004
    Ort
    Überlingen/Bodensee
    Alter
    39
    Beiträge
    4.308
    Wie sind die Filtereinstellungen des IP-Routers ?
    Gruss,

    Michael

  3. #3
    Registriert seit
    May 2004
    Ort
    Nürnberg
    Alter
    59
    Beiträge
    646
    Busverbindung über Routing oder Tunneling?

  4. #4
    Registriert seit
    Jan 2016
    Ort
    Speyer
    Beiträge
    6
    Beides gute Fragen - das weiß ich nicht. Ich werde die Antworten schnellstmöglich nachliefern (vmtl. noch heute Abend). Vielleicht liegt da ja schon der Hund begraben... Danke schonmal für Eure Reaktion!

  5. #5
    Registriert seit
    Jan 2016
    Ort
    Speyer
    Beiträge
    6
    Q: Wie sind die Filtereinstellungen des IP-Routers ?

    • Ich bin mir nicht sicher: Bei den Parametern findet sich (Standardwerte):
      • Hauptlinie > Einstellungen: Gruppen, Phys. filtern
      • Hauptlinie > Gruppentelegramme: filtern
      • Hauptlinie > Hauptlinien 14/15 Gruppentelegramme: alles weiterleiten
      • Hauptlinie > Physikalische Adressen: filtern

    • Und bei der Nebenlinie, das gleiche wie oben, nur zusätzlich:
      • Nebenlinie > Physikalische Adressen: Wiederholung bei Fehlern auf Linie: normal
      • Nebenlinie > Gruppenadressen: Wiederholung bei Fehlern auf Linie: normal
      • Nebenlinie > Telegramm Bestätigung auf Hauptlinie: wenn weitergeleitet
      • Nebenlinie > Sendebestätigung bei eigenen Telegrammen: nein
      • Nebenlinie > Konfiguration aus der Nebenlinie: aktivieren


    Q: Busverbindung über Routing oder Tunneling?

    • Sorry, keine Ahnung, wo/wie ich das einsehen kann. Topologie ist: PC > Ethernet > Switch > Ethernet > IP Router - falls das irgendwie hilft :-(

  6. #6
    Registriert seit
    May 2004
    Ort
    Nürnberg
    Alter
    59
    Beiträge
    646
    Zitat Zitat von Saccoon Beitrag anzeigen
    Sorry, keine Ahnung, wo/wie ich das einsehen kann. Topologie ist: PC > Ethernet > Switch > Ethernet > IP Router - falls das irgendwie hilft :-(
    Welche ETS-Version hast du?

  7. #7
    Registriert seit
    Jan 2016
    Ort
    Speyer
    Beiträge
    6
    Ich habe die ETS 5.0.8

  8. #8
    Registriert seit
    May 2004
    Ort
    Nürnberg
    Alter
    59
    Beiträge
    646
    Dann auf der Hauptseite auf "Bus" gehen und schauen, was deine aktuelle Schnittstelle ist. Netzwerkkartensymbol = Routing, "Röhren" = Tunneling

  9. #9
    Registriert seit
    Jan 2016
    Ort
    Speyer
    Beiträge
    6
    Ich sehe Röhren. Außerdem steht oben rechts IP-Tunneling.

  10. #10
    Registriert seit
    Jan 2016
    Ort
    Speyer
    Beiträge
    6
    Nach viel Rumprobieren habe ich eine "Lösung" - oder vermutlich nur einen Workaround: Wenn ich die Router-Einstellung folgendermaßen ändere:
    Nebenlinie > Gruppenadressen: Wiederholung bei Fehlern auf Linie: normal => nein
    klappt alles. Es scheint also irgendein Fehler auf dem Bus zu entstehen, der den IP Router dazu veranlasst, das "Wer ist im P-Modus"-Telegramm mehrfach zu schicken, woraufhin der Stetigregler auch mehrfach antwortet.

    Seltsamerweise leuchtet die "Bus Error" LED an der Spannungsversorgung nun nicht mehr...

    Naja... Danke für Eure Antworten

    PS: Umstellung von Tunneling auf Routing hat keinen Unterschied gemacht - falls Ihr darauf hinaus wolltet

  11. #11
    Registriert seit
    May 2004
    Ort
    Nürnberg
    Alter
    59
    Beiträge
    646
    Zitat Zitat von Saccoon Beitrag anzeigen
    PS: Umstellung von Tunneling auf Routing hat keinen Unterschied gemacht - falls Ihr darauf hinaus wolltet
    Nein, im Gegenteil. Tunneling ist viel weniger störanfällig (da es einen Bestätigungsmechanismus enthält und da es über IP unicast statt IP multicast läuft und daher weniger Nebeneffekte aus dem IP-Netzwerk zu befürchten sind).

    Gruß, Klaus

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •